This page is READ-ONLY. It is generated from the old site.
All timestamps are relative to 2013 (when this page is generated).
If you are looking for TeX support, please go to VietTUG.org

Rails 2.3.5 and Rack 1.0.1

Added by over 2 years ago  »  Votes: 2/2

Redmine 1.x requires Rack 1.0.1 and Rails 2.3.5; but Rails cannot load Rack 1.0.1 while reporing Rack 1.2.1 already activated (if you're using 1.2.1 or any higher version of Rack). To get rid of this error, you can follow some intructions on DreamHost's wiki: http://wiki.dreamhost.com/Ruby_on_Rails#Rails_2.3.5_-_Rack_1.0_already_activated_.28fix.29

$ cd RAILS_ROOT/vendor/gems && gem unpack rack -v=1.0.1

Edit the file RAILS_ROOT/vendor/rails/actionpack/lib/action_controller.rb

1 # gem 'rack', '~> 1.0.1'                                  # old line
2 # require 'rack'                                          # old line
3 load "#{RAILS_ROOT}/vendor/gems/rack-1.0.1/lib/rack.rb"   # new line

Comments